Skip to content

CRAIG 5.6.2

Below is a summary of the JIRA issues addressed in the CRAIG-5.6.2 release of Punchplatform. For full documentation of the release, a guide to get started, and information about the project, see the Punchplatform project site.

Note about upgrades: Please carefully review the upgrade documentation for this release thoroughly before upgrading your cluster. The upgrade notes discuss any critical information about incompatibilities and breaking changes, performance changes, and any other changes that might impact your production deployment of Punchplatform.

The documentation for the most recent release can be found at https://doc.punchplatform.com.

Release summary

This release:

  • fixes issues related to Filebolt
  • provide a high-level templating to the deployer
  • finalize the history of Punch within Nifi

Patch changes

Please read the Migration Guide from 5.6.0 to 5.6.2

Release notes

Features

  • [PP-3687] - Provide deployer high-level configuration templating
  • [PP-3671] - Create a Punch "ControllerService" for Nifi

Internal

  • [PP-3401] - Set a skeleton of a Punch Gateway
  • [PP-3646] - Add Pyspark to the deployer

Bug

  • [PP-3505] - Fix FileBolt destination Ceph configuration regression
  • [PP-3607] - Fix Elastic parametered input PML with the new PML convention
  • [PP-3623] - Fix the Syslog spout nullpointer
  • [PP-3658] - Fix NullPointer when using the stream "_ppf_errors" in Kafka spout
  • [PP-3681] - Fix Punchctl deployment without Storm libs installed (LTR)
  • [PP-3682] - Add missing extra PP fields to Elastic Beats
  • [PP-3686] - Filebolt "at_least_once" error type on field 'partition_id'
  • [PP-3688] - Storm Supervisor monitoring in 'unknown' status when no more available memory or slots
  • [PP-3690] - Potential Filebolt 'boltUUID' conflict with multiple executors
  • [PP-3691] - Fix Filebolt memory direct allocation when GZIP is choosen
  • [PP-3693] - Unable to deploy beats when using 'brokers_with_ids' in the Kafka section
  • [PP-3703] - Filebolt "at_least_once" do not ack Tick tuples
  • [PP-3706] - Kibana plugin not using http_api_address when create extraction