Skip to content

DAVE 6.1.0

Below is a summary of the JIRA issues addressed in the DAVE-6.1.0 release of Punchplatform. For full documentation of the release, a guide to get started, and information about the project, see the Punchplatform project site.

Note about upgrades: Please carefully review the upgrade documentation for this release thoroughly before upgrading your cluster. The upgrade notes discuss any critical information about incompatibilities and breaking changes, performance changes, and any other changes that might impact your production deployment of Punchplatform.

The documentation for the most recent release can be found at https://doc.punchplatform.com.

Release summary

Important changes

  • JDK 8 version >= 241

Release notes

Release notes - Punch - Version Dave-6.1.0

Overview

Security

Warning

New security features for Dave-6.1.0 needs at least JDK 8 with a version superior or equal to 241

The standalone can be installed with a security option :

./install.sh --with-security

Check security documentation at Getting Started - Security.

Epic

Bug Fix

New Feature

Improvement

  • [PP-4094] SSL certificate authentication support for Punch EsRestClient
  • [PP-4117] Security option for standalone installation

Task