Skip to content

5.5.0 to 5.5.1

This document explains what configuration changes MUST be performed during a PunchPlatform update from version 5.5.0 to 5.5.1

General changes

Important

Before upgrading it is recommended to stop all your topologies. If this is a concern to you, make sure you have each topology file have a name property that matches the file name. See an example below.

Configuration files

punchplatform.properties punchplatform-deployment.settings

All Elastic components (elasticsearch, kibana, beats...) are upgraded from 6.7.1 to 6.8.2.
This version upgrade is fully compatible.

All Opendistro components (alerting, sql, security) are upgraded from 0.9.0.0 to 0.10.0.1.
This version upgrade is fully compatible.